Join 10350+ others. No spamming.
I promise!

Follow us at github.



puniverse/pulsar

635

puniverse / pulsar

Clojure

Fibers, Channels and Actors for Clojure


READ ME

Pulsar
Fibers, Channels and Actors for Clojure

Build Status Dependency Status Version License License

Pulsar wraps the Quasar library with a Clojure API that's very similar to Erlang.

Requirements

Java 7 and up and Clojure 1.5 and up are required to run Pulsar.

Getting started

Add the following dependency to Leiningen's project.clj:

[co.paralleluniverse/pulsar "0.7.3"]

Then, the following must be added to the project.clj file:

:java-agents [[co.paralleluniverse/quasar-core "0.7.3"]]

or, add the following to the java command line:

-javaagent:path-to-quasar-jar.jar

Alternatively, to build Pulsar from the source, clone the repository and run:

lein midje

You can run the examples like this:

lein -o run -m co.paralleluniverse.pulsar.examples.pingpong

For benchmarks, you should use lein trampoline, like so:

lein trampoline run -m co.paralleluniverse.pulsar.examples.ring-benchmark 1000 1000

Usage

Documentation and examples can be found here.

You can also read the introductory blog post.

When running code that uses Pulsar, the instrumentation agent must be run by adding the following to the java command line or to the :jvm-opts section in project.clj:

-javaagent:path-to-quasar-jar.jar

Documentation

Community

License

Pulsar is free software published under the following license:

Copyright © 2013-2015 Parallel Universe

This program and the accompanying materials are dual-licensed under
either the terms of the Eclipse Public License v1.0 as published by
the Eclipse Foundation

  or (per the licensee's choosing)

under the terms of the GNU Lesser General Public License version 3.0
as published by the Free Software Foundation.

githalytics.com alpha